
Instructions for GenMAPP Hands-on Tutorial 
 
These instructions for using GenMAPP were specifically designed for a tutorial setting, and are 
intended to be used in conjunction with a set of tutorial files. These instructions do not represent 
a complete user’s manual, for detailed information on using the GenMAPP program; please refer 
to our Help documentation (http://www.genmapp.org/help_v2/GenMAPP.htm).  
 
Some steps in this tutorial have been illustrated with video, follow the links to view the videos. 
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1 Installing and Setting up GenMAPP 
 

1.1 Go to at GenMAPP.org/workshop.html and follow the instructions for installing 
GenMAPP and downloading accessory files. 

1.2 Browse to the folder you downloaded the files to and double-click the Mm-
Slim_20060127.exe file. The file will automatically extract to the correct folder. 
Repeat with the gcrma_ES_EB-expression.exe, Mm_Contributed_short.exe and 
_ED_Myometrium-pregnancy-mu11kAB_gcrma_20060612.exe. 

1.3 Verify that there are GenMAPP and MAPPFinder icons on your desktop. To make 
sure the installation worked; try launching GenMAPP by double-clicking the icon. You 
may be prompted for an update. If so, agree to the update. 

 Start with sections 1-3, which deal with basic GenMAPP operations necessary for any data. 

 To continue, select anyone of sections 4-8. 
 If you would like to work with your own data or want to use GenMAPP for a specific purpose, 

talk to the instructor before the workshop. 



2 Formatting Data for GenMAPP 
 

2.1 Browse to the C:\GenMAPP 2 Data\Expression Datasets folder and open the 
gcrma_ES_EB-expression.xls file in Excel. 

2.2 Verify that the first and second columns of the file contain the identifier and system 
code, respectively. 

 
VIDEO http://freescreencast.com/screencasts/watch/396 
 

 

3 Creating an Expression Dataset 
 

3.1 Launch the GenMAPP application by double-clicking the Desktop icon.  
 

Select Gene Database 
 

3.2 To load the appropriate Gene Database for your data, go to Data > Choose Gene 
Database. Browse to the C:\GenMAPP 2 Data\Gene Databases folder and select the 
Mm-Slim_20060127 database. 

 
Importing the data 
 
3.3 Open the Expression Dataset Manager (EDM) under Data > Expression Dataset 

Manager in the main window of GenMAPP. In the EDM, go to the Expression 
Datasets > New Dataset menu item. Select your raw data file saved under 2.7 above 
(gcrma_ES_EB-expression.txt), from the file dialog box that appears and click OK. If 
an Expression Dataset (.gex file) already exists with that name in the same folder, 
you will be asked if you want to overwrite the existing file.  

3.4 If your data is formatted correctly, the Data Type Specification window will appear. 
Check the Data Type Specification window to confirm that GenMAPP was correct in 
guessing the data type (numeric or character) of the columns in your data, then click 
OK.  

 
NOTE: The data type must be consistent within each column; a column designated 
as numeric must contain only numeric values, and a character column can contain 
values consisting of up to 30 characters, including spaces. If a column is designated 
as a character column, regular numeric expressions cannot be used in criteria 
involving that column.  
 

VIDEO http://freescreencast.com/screencasts/watch/398 
 

 
Exceptions during import 

 
If GenMAPP encounters any errors in your file during import, a message will appear at the 
end of the import process. Errors are stored in an exception file, which will be of the same 
type as your input data (e.g. .txt or .csv). For example, errors from your file gcrma_ES_EB-
expression.txt, will be stored in a file called gcrma_ES_EB-expression.EX.txt, in the same 
folder as your raw data file and Expression Dataset. 

 
3.5 Locate the exception file and open it in Excel.  
3.6 Examine the error messages in the “~Error~” column.  
 
Note: In the case of the example data, all errors are due to Affymetrix control probes (starting 
with AFFX) not being imported. These errors can be ignored, since all relevant probes re 
imported successfully.  
 



 
Customizing an Expression Dataset 

 
When the import process is complete, your converted dataset is displayed in the Expression 
Dataset Manager window active and ready to be manipulated. The file is saved in the same 
folder as your raw data file, with a .gex extension (gcrma_ES_EB-expression.gex). 

 
 
Creating Color Sets 

 
Color Sets contain the instructions to GenMAPP for displaying data from an Expression 
Dataset on MAPPs.  
 
3.7 Enter general information about the dataset in the top portion of the EDM.  
3.8 In the Name field of the Color Sets section, enter “EB vs ES” (without the quotes) as 

the name.  
3.9 In the Gene Value drop-down, select the “Fold” value to display from the list of values 

in your dataset. The value will be displayed to the right of the gene box on the MAPP. 
You can also select to not display a value, by selecting the [None] option. 

3.10 In the Criteria Builder, click the New button to activate the fields in the Criteria 
Builder. 

3.11 Enter a label, “Up-regulated, EB vs ES” (without quotes), for the criterion in the Label 
in Legend field. This should be a descriptive label since it will appear in the legend on 
the MAPP. 

3.12 Click the Color field to select a color for your criterion. You can choose any color 
other than white. 

3.13 Setup the coloring criterion in the Criterion field, by choosing from the Columns and 
Ops fields. For example, clicking on “Fold EB vs ES” in the Columns field will make it 
appear in the Criterion field.  

3.14 Next, click the “>” sign in the Ops field.  
3.15 In the Criterion field, to the right of the “>” sign, type in “1.2” (without quotes).  
3.16 Next, select the “AND” operator from the Ops field, and then select “rawp” from the 

Columns field.  
3.17 Select the “<” sign from the Ops field and then type in “0.05 to the right of it (without 

the quotes).  
 

This should result in the following criterion: 
 

[Fold EB vs ES] > 1.2 AND [rawp] < 0.05 
 
3.18 Click the Add button. The criterion will now appear in the criterion list below. 
3.19 Repeat steps 12-19, this time creating a criterion for down-regulation of the same 

magnitude, that is  
 

[Fold EB vs ES] < -1.2 AND [rawp] < 0.05 
 
3.20 Once you have created all the criteria you want in a Color Set, go to the Expression 

Datasets menu and select Save. Then exit the EDM by selecting Exit or simply close 
the window.  

 
VIDEO http://freescreencast.com/screencasts/watch/400 

 
 

3 Viewing Data on MAPPs 
 

4.1 In the GenMAPP main window, go to File > Open and browse to C:\GenMAPP 2 
Data\MAPPs\Mm_Contributed_short\cellular_process-
GenMAPP\Mm_ESC_Pluripotency_Pathways.mapp. Click Open.  



 
VIDEO http://freescreencast.com/screencasts/watch/388 
 
4.2 In the Toolbar, there will be a drop-down field displaying “No expression data”. 

Clicking on the drop-down arrow will reveal a menu, where you can either choose a 
single Color Set, or a “Multiple Color Sets” option. For now, click on the “EB vs ES” 
Color Set. Click the OK button. 

4.3 Once the data loads, the MAPP will be colored based on your criteria, and a legend 
will be displayed. 

 
VIDEO http://freescreencast.com/screencasts/watch/389 
 

 
Backpage 
 
4.4 Double-click on any of the gene boxes on the MAPP. This will open the Backpage. 
4.5 In the Backpage, scroll to the bottom of the page to view the original data in the 

imported file. 
4.6 Click on any of the links in the Backpage to view information for the gene at a 

particular public resource. 
4.7 Close the Backpage. 
 
Gene Finder 
 
4.8 Right-click on any of the gene boxes on the MAPP. This opens the Gene Finder, 

which communicates with the Gene Database loaded. 
4.9 The gene ID currently linked to the gene on the MAPP will be displayed in the Gene 

ID field in the upper left corner. To switch this gene ID, copy any of the gene IDs in 
the window, paste it into the Gene ID field.  

4.10 Switch the Gene ID System drop-down to the corresponding system. Click Search.  
4.11 Once the search is done, click OK in the bottom right corner to agree to the change. 
 
VIDEO http://freescreencast.com/screencasts/watch/392 
 



 

5 Viewing Complex Data in GenMAPP 2.1 

Mouse Uterine Pregnancy Timecourse  
The Mm_ED_Myometrium-pregnancy-mu11kAB_gcrma_20060612.gex dataset describes the 
myometrium throughout and after pregnancy. The data analyzed has two baselines, virgin 
non-pregnant (NP) myometrium and mid-pregnancy myometrium (14 days). This comparison 
allows the user to simultaneously examine the effects of pregnancy as compared to non-

pregnant animals and the specific temporal effects leading up to labor through postpartum.  

The prostaglandin synthesis and regulation pathway contains molecular interactions that are 
critical in the transition of the myometrium from a relatively quiescent tissue throughout 
pregnancy to a highly contractile tissue at term. By viewing multiple time-point comparisons in 
the context of this pathway, one can determine which molecules are differentially expressed 
just prior to the onset of labor (18 days of pregnancy) relative to mid-pregnancy (14 days of 
pregnancy) in addition to the relative expression of these genes at mid-pregnancy versus the 

virgin state. 

5.1 Launch GenMAPP and load the Mm-Slim_20060127 database.  
5.2 Under Data>Choose Expression Dataset, select the Mm_ED_Myometrium-

pregnancy-mu11kAB_gcrma_20060612.gex. 
5.3 In the GenMAPP main window, go to File > Open and browse to C:\GenMAPP 2 

Data\MAPPs\Mm-Contributed_short\physiological_process-GenMAPP\ 
Mm_Smooth_muscle_contraction.mapp. Click Open.  

5.4 In the Toolbar, there will be a drop-down field displaying “No expression data”. 
Clicking on the drop-down arrow will reveal a menu, where you can either choose a 
single Color Set, or a “Multiple Color Sets” option. This time, select “Multiple Color 
Sets”.  

5.5 A separate window will appear, with the available Color Sets listed in the left-hand 
panel. To select multiple Color Sets, hold down the Ctrl key while clicking on each 
Color Set. Select the following Color Sets:  

 
14 days vs. Virgin 
16 days vs. 14 days 
17 days vs. 14 days 
18 days vs. 14 days 
6h Post vs. 14 days 
24h Post vs. 14 days 

 
5.6 In the right-hand panel, you can choose a value to display on the MAPPs. In this 

case, we will choose the “Don’t display value” option. Click OK. 
5.7 Once the data loads, you will see data from all Color Sets displayed as “stripes” in 

each gene box.  
5.8 The Legend refers to the first Color Set chosen. To view the Legend for each Color 

Set, go to Tools>Options>Legend and check the box at the bottom for Show All. 



 

6 MAPPFinder Analysis 
 

For this exercise we will use the gcrma_ES_EB-expression.gex file completed in section 3 
above. DO NOT use the Mm_ED_Myometrium-pregnancy-mu11kAB_gcrma_20060612.gex 
for this. 
 
6.1 Launch MAPPFinder from the Desktop icon. 
6.2 In the main menu that appears, check to make sure the correct database is loaded. If 

not, go to File > Choose Gene Database to load the correct database. 
 
Loading Local MAPPs 
 
6.3 Click the Load Local MAPPs button. In the browser that appears, click the Choose 

Folder button and select the Mm_Contributed_short archive. Make sure to click twice 
on the folder to display the subfolders. Click the OK button. 

6.4 Once Local MAPPs are loaded, they do not have to be reloaded on subsequent 
MAPPFinder runs, unless the MAPP archive has changed.  

 
Setup the analysis 
 
6.5 Click the Calculate New Results button. Find the gcrma_ES_EB-expression.gex file 

and click OK. 
6.6 In the window that appears, select the EB vs ES Color Set in the top left panel. The 

criteria available in the Color Set will appear in the top right panel.  
6.7 In the Criteria panel, select both the up-regulated and down-regulated criteria. 
6.8 Select all three analysis options; Local MAPPs, Gene Ontology and Calculate p-

values. 
6.9 Click the Browse button and choose a location and name for your results. 
6.10 Click the Run MAPPFinder button to start the analysis. The analysis may take 

several minutes to finish. 
 
4 Viewing MAPPFinder results in the MAPPFinder Browser 
 
6.11 When the calculation is complete, the results will open in the MAPPFinder browser. 

The tree structure is expanded based on the default filtering criteria visible in the top 
part of the browser. 

6.12 Change the filtering criteria by changing the stringency of the p-value to see how the 
tree changes.  

6.13 Click on any MAPP or GO term in the tree and view the corresponding MAPP in 
GenMAPP. At this point, the MAPP can be saved as a .mapp file for later use.  

6.14 In the Options menu, choose the Set click response. In the window that opens, check 
the option for Export the list of genes in my Expression Dataset……. Close out of the 
Click Options window. Click on any term or MAPP again and this time a window will 
appear showing the changed genes as well as all genes in the term/MAPP. In the 
menu, select Export This List as Text to save this list as a text file. 

6.15 In the keyword field at the top of the browser, type in “transcription” (without the 
quotes). This highlights all terms and MAPPs matching the keyword. Go to File > 
Export Terms Matching Word/Gene ID Search to export all highlighted terms as 
MAPPs. You will be prompted to select a folder name for your export, the export will 
appear under C:\GenMAPP 2 Data\MAPPs\MAPPFinder under a species-specific 
folder named by the two-letter code for that species. 

6.16 To view a ranked list of all changed GO terms and MAPPs, go to the menu item 
Show Ranked List. This list can also be saved as text.  

 
VIDEO http://freescreencast.com/screencasts/watch/401 
 
 



 
Viewing MAPPFinder results in text format 
 
6.17 MAPPFinder results are also stored as text files, in the folder that was chosen when 

setting up the analysis. Browse to this folder and open the file gcrma_ES_EB-
expression-Criterion0-Local.txt in Excel. (There is also a corresponding file for the 
GO results) 

 The text file includes a summary of the analysis as well as the results of all local 
MAPPs loaded. You can use this file to filter and sort based on Z-score etc. 

 
 

7 Exporting MAPPs 
 

Export MAPP as image file 
 
7.1 Open a MAPP from the Mm_Contributed_short archive. 
7.2 Under the File menu, select Export > MAPP > To JPG. A file browser will appear 

asking you to select a destination and name for the export. The MAPP can also be 
saved in BMP format. 

 
Export MAPP as pdf for publications 
 
7.3 Open the MAPP in GenMAPP. 
7.4 Under File > Print, choose Adobe PDF writer as the printer. You will be prompted to 

enter a destination for your export. 
 
MAPP Set Export 
 
7.5 Repeat the export, this time choosing Export > MAPP Set.  
7.6 In the MAPP Sets window that appears, select the folder of MAPPs you want to 

export in the MAPP Source browser to the left. To select a folder with subfolders, 
simply select the parent folder and then check the box for Include subfolders. 

7.7 In the HTML destination browser to the right, select a location for storing your MAPP 
Set. You can also create a new subfolder here. 

7.8 To include data in the export, click the Choose Expression Dataset button to select a 
.gex file. Select which Color Sets you wish to include in the export. 

7.9 Click Create Set to start the export. 
7.10 Once MAPP Set export is complete, the destination folder will contain a set of Index 

files for navigating the MAPP Set export. 
 
 

8 Creating MAPPs 
 

Creating a MAPP by hand 
 

8.1 In the GenMAPP main window, go to File > New. You may be prompted to save the 
changes on the current MAPP. 

8.2 Click on the Gene icon on the Toolbar, then click anywhere on the blank canvas to 
place the gene.  

8.3 Right-click the gene box to bring up the Gene Finder, then type in 20224 in the Gene 
ID field, select EntrezGene from the drop-down and click Search.  

8.4 In the results that appear in the Gene Finder, copy the gene symbol and paste it into 
the Gene label field. Close out of the Gene Finder. 

8.5 Select a line type in the drop-down menu in the Toolbar. Click twice on the drawing 
board to draw the line. 

8.6 Right-click on the line to add a comment. 



8.7 Click on the label in the Toolbar and place the label on the drawing board. Right-click 
on the label to name it. 

8.8 You can also add any other objects from the Toolbar to your MAPP. Once you are 
done, go to File > Save As to save your MAPP. 

 
VIDEO http://freescreencast.com/screencasts/watch/393 

 
 

Creating a MAPP using MAPPBuilder 
 
The MAPPBuilder tool can be used to create a simple MAPP based on a set of genes. For 
details on how to use it, see our Help documentation 
http://www.genmapp.org/help_v2/MAPPBuilder.htm 
 
VIDEO http://freescreencast.com/screencasts/watch/395 

 


